New Site Online
admin
moderator
founder
Posted by MilesCity.com Webmaster (+9203) 3 years ago
Welcome to 2015!

The new/updated version of this site is now online. You're looking at it.

There's still more work to do, but everything important should be operational. Also, there are a lot of new features hiding about, which may not be apparent at first glance. For example, you can now "Like" (or "Dislike") posts. You can now upload images to Classified Ads. Etc. (I'll write more about them later.)

Everyone from the old site will need to log back in. Let me know if you experience any problems. I'm sure there will be kinks and bugs to work out, and there are still a few missing areas that need be re-added. Also, there are other new areas still under development which have not yet been published.

Anyway, enjoy and Happy New Year.

Regards, Larry
MilesCity.com Webmaster
Top
+6
supporter
sponsor
Posted by Matt Smith (+794) 3 years ago
Congrats!

Is there a specific size upload for a profile image?
Top
admin
moderator
founder
Posted by MilesCity.com Webmaster (+9203) 3 years ago
The site will autocrop to the correct size and cache the result. The profile image is 120x120, but it doesn't matter if you upload larger. I believe the maximum size is 4MB. Basically, a square image should look best. You can easily remove or replace your uploaded image if it doesn't look right. Try it out and see if it works. If not, let me know!
Top
admin
moderator
founder
Posted by MilesCity.com Webmaster (+9203) 3 years ago
Also, the old site can be found at http://classic.milescity.com, should anyone want to use it instead.
Top
Posted by Kacey (+3146) 3 years ago
I really like it! Thank you so much for all your work.
Top
supporter
Posted by Karen L. Morris (+683) 3 years ago
Looks beautiful, Larry! Thank you so much for all your hard work--you are more than appreciated, even if it isn't always said. Happy New Year and all the best in 2015 to you and yours!
Top
supporter
Posted by Shu (+1324) 3 years ago
Nice...it'll take some getting used-to but I'm game. Thanks for all your work as always, webmaster.
Top
founder
supporter
sponsor
Posted by Hal Neumann (+8861) 3 years ago
Thanks Larry.
Top
supporter
Posted by Jeri Dalbec (+2600) 3 years ago
Thanks Larry, I am kind of liking this old Classic Version better for some reason. Nice of you to offer one or the other?
Top
supporter
sponsor
Posted by Hannah Nash (+2449) 3 years ago
I attempted to upload a profile photo (on iPhone 5s, running latest iOS). Tried a few times and it doesn't appear to have worked. Do I need to do this from the computer?
Top
admin
moderator
founder
Posted by MilesCity.com Webmaster (+9203) 3 years ago
Hannah Nash wrote:
I attempted to upload a profile photo (on iPhone 5s, running latest iOS). Tried a few times and it doesn't appear to have worked. Do I need to do this from the computer?


Thanks for reporting! It doesn't appear to be working. I'm looking into it.
Top
admin
moderator
founder
Posted by MilesCity.com Webmaster (+9203) 3 years ago
Profile image uploading should be fixed now. Let me know!

Also, I temporarily removed the Flickr gallery preview from the front page -- since it was slowing down the site.

Regards, Larry
Top
founder
supporter
sponsor
Posted by Hal Neumann (+8861) 3 years ago
Yup, the image loader seems to be working fine.
Top
supporter
Posted by Richard Bonine, Jr. (+13743) 3 years ago
Wow, Larry, this is SO COOL.  I appreciate all of the effort you have put into this new site. It looks really great!
Top
admin
moderator
founder
Posted by MilesCity.com Webmaster (+9203) 3 years ago
Thanks. This is just the basic foundation for moving forward. Everything had to be rewritten from scratch to make it possible. I'm still working on a lot of new features, and what is already here will continue to be improved as I figure out what works or not. As always, let me know your opinions!

Regards, Larry
Top
supporter
Posted by Gene S. (+268) 3 years ago
Thank you for all you do.
Top
supporter
sponsor
Posted by Matt Smith (+794) 3 years ago
Looks like the "Founder" badge is working overtime.
Top
founder
supporter
Posted by Tucker Bolton (+2955) 3 years ago
Bravo and thank you. I can't believe it has been twelve years since I joined the fray.
Top
supporter
Posted by MRH (+1297) 3 years ago
Thanks Larry, it looks nice. Tucker, where is your banjo?
Top
Posted by snickers (+798) 3 years ago
I was looking for the Eagle Cam link But didn't see a search button
Top
admin
moderator
founder
Posted by MilesCity.com Webmaster (+9203) 3 years ago
Matt Smith wrote:
Looks like the "Founder" badge is working overtime.


Hah. I initially assigned the "Founder" badge award to anyone who signed up to the site before 1/1/2003, however that was an arbitrary date.

User accounts came into existence on 9/30/2000. As such, I've adjusted the "Founder" badge to represent those who registered on the site before 9/30/2002 -- a period representing the first two years of user registration and the first two years of the discussion forums.

Glad to see many are still around!

Regards, Larry
Top
admin
moderator
founder
Posted by MilesCity.com Webmaster (+9203) 3 years ago
snickers wrote:
I was looking for the Eagle Cam link But didn't see a search button


No search here yet. (Still working on it.) If needed, you can still find it at the old version of the site: http://classic.milescity.com/search
Top
Posted by snickers (+798) 3 years ago
LOL That's what I ended up doing. I wasn't sure of my blond roots were coming through and I couldn't find it or if there wasn't one
Top
+1
supporter
Posted by Richard Bonine, Jr. (+13743) 3 years ago
Thanks for the search link. In a dream last night, "the girls" told me that they had been left behind. 

[Edited by Richard Bonine, Jr. (1/2/2015 7:24:19 AM)]
Top
Posted by snickers (+798) 3 years ago
Awww Richard Only the Blond ones
Top
+1
Posted by Rob Reukauf (+97) 3 years ago
I can't get into the site the usual way, but have to go through facebook and hit the links. I went to the new site and re-logged in , but still can't access it the usual way. I wonder how come?
Top
supporter
Posted by Wendy Wilson (+6174) 3 years ago
I'm not loving this new site. The font seems smaller and the font for composing a note is something like a typewriter. Everything just seems smaller and harder to use.
Top
admin
moderator
founder
Posted by MilesCity.com Webmaster (+9203) 3 years ago
Rob Reukauf wrote:
I can't get into the site the usual way, but have to go through facebook and hit the links. I went to the new site and re-logged in , but still can't access it the usual way. I wonder how come?


I actually have no idea what you mean. Please let me know more details. For example, you were apparently able to post, but I'm not clear what "but still can't access it the usual way" means. More info please.
Top
admin
moderator
founder
Posted by MilesCity.com Webmaster (+9203) 3 years ago
Wendy Wilson wrote:
I'm not loving this new site. The font seems smaller and the font for composing a note is something like a typewriter. Everything just seems smaller and harder to use.


Likewise, I also don't understand this. I need more info. "The font seems smaller" -- that should not be the case. Are you sure your browser is not set to display type at a smaller percentage than 100%?

Also "the font for composing a note is something like a typewriter" -- I don't understand what that means. The old site displayed messages using a serif font, this one a non-serif -- which is very un-typewriter-like.

In any case, I need more info. Post or e-mail screenshots if necessary, or let me know your particular browser configuration so I can test it out. Thanks!
Top
moderator
founder
Posted by David Schott (+12829) 3 years ago
I believe Wendy is referring to the font used on the "Post Reply" page in the edit control where you enter your message text.
Top
admin
moderator
founder
Posted by MilesCity.com Webmaster (+9203) 3 years ago
David Schott wrote:
I believe Wendy is referring to the font used on the "Post Reply" page in the edit control where you enter your message text.


Hmm. Okay. Yes, that's a serif font. I thought it was the same, or similar to the old site. If that doesn't work, I can make it larger or change it to a sans-serif font. Let me know. All of this is a work in progress!

Regards, Larry
Top
supporter
Posted by Richard Bonine, Jr. (+13743) 3 years ago
Or Wendy could just put her bifocals on :ducking:
Top
+1
Posted by Rob Reukauf (+97) 3 years ago
I had it on my favorites list, and after the change it would simply come up with error 404 and not connect. By going through facebook to access the link to the new site, I was able to discern that the new site had milescity.com/home which I added to my favorites list, and it now works from the favorites. The old site URL was showing "default" behind miles city.com, and would not work although it always had up to the change. At any rate all is well-thanks for the time and effort put into this site.
Top
founder
supporter
Posted by Tom Masa (+1676) 3 years ago
No complaints. Seems to be working ok.
Top
supporter
Posted by Wendy Wilson (+6174) 3 years ago
I'm on Safari on my iPad. Maybe that's the issue?

Ha, ha, Richard. I don't need bifocals.
Top
supporter
Posted by MRH (+1297) 3 years ago
Responses to the individual classified adds are not showing, just the original appears. I do not think it was this way on Saturday.
Top
moderator
founder
Posted by David Schott (+12829) 3 years ago
I'm seeing the replies to the classified ads. What browser version are you using, MRH?
Top
supporter
Posted by MRH (+1297) 3 years ago
I don't see them with Firefox, but I do with IE. They were there earlier with Firefox.
Top
admin
moderator
founder
Posted by MilesCity.com Webmaster (+9203) 3 years ago
MRH wrote:
I don't see them with Firefox, but I do with IE. They were there earlier with Firefox.


That's odd. Everything looks fine with the version of Firefox I'm using. Can you post a screenshot or let me know what version you are using? Mine says "29.0.1".

EDIT: I updated to "33.0.3". Still looks okay.
EDIT: Updated again to "34.0.5". Still looks okay?

I'm running Windows 8.1. What OS do you have?

Top
admin
moderator
founder
Posted by MilesCity.com Webmaster (+9203) 3 years ago
Wendy Wilson wrote:
I'm on Safari on my iPad. Maybe that's the issue?


The font for the edit control is set to "Courier New, Courier, monospace" at 12px. Perhaps that is not a good selection for the iPad.

This is what it looks like to me:



Does it look different to you?
Top
moderator
founder
Posted by David Schott (+12829) 3 years ago
The classified ad replies appear correct to me using Firefox 34.0.5 on Windows XP.

MRH, you might want to try deleting your temporary Internet files in Firefox and restarting Firefox to see if that addresses the issue.
Top
supporter
Posted by MRH (+1297) 3 years ago


http://i492.photobucket.c...ty_com.jpg

Firefox 34.0.5

[Edited by MRH (1/4/2015 12:45:08 PM)]
Top
admin
moderator
founder
Posted by MilesCity.com Webmaster (+9203) 3 years ago
That is weird. It looks like this to me:



http://cdn.milescity.com/...eplies.jpg

Also, Firefox 34.0.5.

Do you perhaps have ad blocking software installed?
Top
admin
moderator
founder
Posted by MilesCity.com Webmaster (+9203) 3 years ago
@MRH (#355829) - I suspect perhaps ad blocking software was blocking some of the content in the Classified Ads area. ??? In case that was the issue, I changed some of the code to try and bypass that. Let me know if it made any difference. Thanks!
Top
supporter
Posted by MRH (+1297) 3 years ago
Thanks, it works fine now.
Top
supporter
Posted by Wendy Wilson (+6174) 3 years ago
My version looks the same. I guess I don't like courier. No worries. I'll get used to it. And I forget that I can enlarge my screen with a touch.
Top
Posted by Josh Rath (+2296) 3 years ago
Wendy Wilson wrote:
My version looks the same. I guess I don't like courier. No worries. I'll get used to it. And I forget that I can enlarge my screen with a touch.


Oh Wendy. You crack me up.



Otherwise, looks stellar to me Larry. Little things here and there with your design erk me ever so slightly.. Such as the grey space above the navigation bar, and spacing on certain buttons and breadcrumb navigation (like "Compose" in this reply area) but overall the website is solid. Glad it's online.
Top
Posted by Donald Mullikin (+139) 3 years ago
I'm liking the new site.
Thank you for the hard work.
Top
+2
supporter
Posted by Wendy Wilson (+6174) 3 years ago
Be nice to me, Josh. I am old.
Top
Posted by Josh Rath (+2296) 3 years ago
Wendy Wilson wrote:
Be nice to me, Josh. I am old.


Yes Wendy, hence the need for jokes at that expense! :P



At least you don't pull this trick off, right?
Top
admin
moderator
founder
Posted by MilesCity.com Webmaster (+9203) 3 years ago
Josh Rath wrote:
Otherwise, looks stellar to me Larry. Little things here and there with your design erk me ever so slightly.. Such as the grey space above the navigation bar, and spacing on certain buttons and breadcrumb navigation (like "Compose" in this reply area) but overall the website is solid. Glad it's online.


Thanks, Josh. If you can, please send me a screenshot concerning the spacing issues. Regards, Larry
Top
Posted by Josh Rath (+2296) 3 years ago
Here you go Larry, here is a few of my changes I think would be good for the site. Maybe I'm crazy, however haha.



To clarify on the Navigation buttons, the photo should really just stretch downward behind the buttons right to the long red strip. That way the odd grey area is removed completely. As such with this quickly made example.



Only thing is, the photo wouldn't look very good stretched down in general. The original photo would look best if it was not squished as it is now, but keeping the cowboy also proportional would be best.

EDIT: One thing I noticed while writing this reply Larry, is that my browser was continuously loading on the page. After digging into the network traffic, I noticed Google Analytics and the Add This functionality randomly causes browser issues. Fixed it by closing down my browser fully, then restarting a minute or so later as my memory usage was climbing very high.

[Edited by Josh Rath (1/16/2015 1:56:23 AM)]
Top
admin
moderator
founder
Posted by MilesCity.com Webmaster (+9203) 3 years ago
Oh, I see what you're saying. Actually, there are more tabs to fill up that area - they're just turned off because those areas aren't finished yet. But yeah, it probably would look better that way.

The whole masthead needs to be redone, I'm just making do with that one for now.

The Compose > Preview > Submit progress thing, I just kind of slapped together. I'll improve the look of it when I get a chance.

Josh Rath wrote:
EDIT: One thing I noticed while writing this reply Larry, is that my browser was continuously loading on the page. After digging into the network traffic, I noticed Google Analytics and the Add This functionality randomly causes browser issues. Fixed it by closing down my browser fully, then restarting a minute or so later as my memory usage was climbing very high.


Hmmm, that's odd. Hopefully that doesn't continue otherwise I'll have to remove it. Thanks for letting me know!
Top
Posted by Josh Rath (+2296) 3 years ago
No problem Larry. As a 8 year long member of the website, I feel I can contribute in someway at least. Haha
Top
Posted by Jim Birkholz (+186) 3 years ago
I've never been a fan of the common box-with-profile-info forums style that you switched to, I had liked the more compact stacked-replies style that you pioneered. But, your new box style is the best of the genre IMO, and the changes overall are superbly crafted, as usual.

My biggest issue with the old style was the date format. I like the new relative timestamps better. After comparing the two versions, I find that my initial reaction has less foundation. I don't think the new style is less compact, it just seemed so. Having a place to put badges, while taking up quite a bit of real estate (esp on long posts) is beneficial. I see that you are incorporating some of the better parts of Facebook. It will be interesting to see how the "dislike" button pans out.

I'm jealous of your skills. Thanks for keeping the old style available, I'd like to refer to it now and then. I presume that you'll be using a dual ads/subscription model long term?

Curious, do you spend as much time fighting the Chinese and Russian hacker/scrapers as I do? In addition, I think BingBot is causing me a lot of grief with excess traffic. I've throttled the major bots to 403 pages when the server load goes above a certain threshold, but I was still down for 3 hours tonight.

[Edited by Jim Birkholz (1/26/2015 10:53:36 PM)]
Top
admin
moderator
founder
Posted by MilesCity.com Webmaster (+9203) 3 years ago
Jim, thanks for your feedback and kind words. This updated site is still only partially complete, so lots of new stuff will keep appearing and being improved.

I attempted to rewrite everything multiple times in the past, and those efforts led up to this, which is supposed to look a lot like the old site, but still have new features. What's here now is still just a stepping stone towards the future though. The old site (at http://classic.milescity.com/) will be around for a while, as a companion for those who don't prefer this one.

Spam is a big problem, MilesCity.com gets hit hard with it, but I have a system in place now that I do not believe has allowed a single spam post through since updating. I'm pretty happy with it for the moment. They keep trying, but I don't know why.

Excess traffic doesn't really matter much. For the most part, I have everything fairly efficient (still working on improving it though), distributed between multiple endpoints (web, api, sql, cdn, etc) and have enough horsepower that everything has been running okay so far. It can scale up to whatever is needed (although it can get expensive).

Anyway, still lots more updates and new features coming. It just takes time to write them.

Regards, Larry
Top